navit-project.org

forum for navit navigation tool
It is currently 22 Nov 2017, 11:14
View unanswered posts | View active topics


All times are UTC


Forum rules


Feel free to ask anything here related to the installation and configuration of Navit.

Some notes before your first post:

Please provide as much informations as possible:



Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: problem with translation
PostPosted: 09 Nov 2015, 21:14 
Offline

Joined: 10 Aug 2015, 20:19
Posts: 20
hello
i have made some translation in french for navit but there is some problems
first : all description start with : à
ex : à dans 125 mètre ...
for normal comprehension the "à" must be delete because the "dans" signify the same thing : so i think there is a mistake not in the translation but in the program ?

other strange information :
some instruction missed : ex

%1$s Restez sur les voies de gauche %2$s%3$s

the instruction %2 and %3 are not exist but navit say it : ex:
"rester sur la voie de droite sur en direction de "
in normal description you must have :
"rester sur la voie de droite"
or
"rester sur la voie de droite sur " road name value" en direction de "next road'

could you check it ?


 Profile  
 
 Post subject: Re: problem with translation
PostPosted: 13 Nov 2015, 07:55 
Offline

Joined: 10 Aug 2015, 20:19
Posts: 20
hello

perhaps my problem is not clear : does anybody need more explanation/details ?
Thanks


 Profile  
 
 Post subject: Re: problem with translation
PostPosted: 13 Nov 2015, 17:33 
Offline

Joined: 09 Jul 2013, 17:41
Posts: 82
Tuxi wrote:
perhaps my problem is not clear : does anybody need more explanation/details ?

Hi!

Looks like that...

- What platform and speech engine do you use?
- Do your problems appear only in a modified version of navit?
- Does the second problem relate to the translated string "%1$s Restez sur les voies de gauche %2$s%3$s". Then I can not imagine how gettext gives you "rester sur la voie de droite sur en direction de"
- Can you please attach a diff describing your translation?
- Also a reference to exact road situation where one could reproduce your problems could be useful. For example, reference osm node id values of route endpoints and of the road crossing before which you have broken announcement.


 Profile  
 
 Post subject: Re: problem with translation
PostPosted: 14 Nov 2015, 20:47 
Offline

Joined: 10 Aug 2015, 20:19
Posts: 20
- What platform and speech engine do you use?
android 2.3

- Do your problems appear only in a modified version of navit?
no it's the last from f-droid

- Does the second problem relate to the translated string "%1$s Restez sur les voies de gauche %2$s%3$s". Then I can not imagine how gettext gives you "rester sur la voie de droite sur en direction de"

no it's for all translation and all actions. , translation is french

- Can you please attach a diff describing your translation?

i have the impression that there are "hard coded" of text in navit translation
for all direction driving:
1: i have the letter A ( in in english) in first position.
2: i think that there are some missed value (%2 or %3) that's why i have this strange behaviour. perhaps the problem come from osm map or navit

- Also a reference to exact road situation where one could reproduce your problems could be useful. For example, reference osm node id values of route endpoints and of the road crossing before which you have broken announcement.

for all situation. you can try to reproduce easily by use navit with french translation

thanks
tuxi


 Profile  
 
 Post subject: Re: problem with translation
PostPosted: 17 Nov 2015, 20:05 
Offline

Joined: 09 Jul 2013, 17:41
Posts: 82
Hi!

Sorry, your problem arose from the fact that we have not imported your most recent translations till yesterday.

Navit is now updated, pushed to F-Droid repository, and accepted there. So update for R6382 should soon be ready on F-Droid.

Alternatively, you may download the version we've built on circleci. To install it, you'll have to uninstall the F-Droid one, and please don't forget to backup Navit internals before uninstalling it.


 Profile  
 
 Post subject: Re: problem with translation
PostPosted: 19 Nov 2015, 10:15 
Offline

Joined: 10 Aug 2015, 20:19
Posts: 20
Thanks !

i try it and it's work fine now


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Silver Orange 2.0.6 for IPB Designed by Skins and Hosting
Converted for phpBB3, based on Royal Blue template by BigB © 2007 2008 AEON KINGS