navit-project.org
http://forum.navit-project.org/

routing problem
http://forum.navit-project.org/viewtopic.php?f=8&t=576
Page 1 of 1

Author:  Tuxi [ 11 Aug 2015, 11:57 ]
Post subject:  routing problem

i encounter a routing problem with navit or osrm at this point :
http://www.openstreetmap.org/export#map ... 97/2.03458

when i program a route from the roundabound to the highway. the system route me to this way (first capture) but there is a turn left restriction that osrm or navit anderstand

the first capture is the good way to use.
the second is bad routing
can anybody check this problem ?

Attachments:
good way.png
good way.png [ 72.45 KiB | Viewed 5507 times ]
File comment: bad routing . turn on a white lane and with a left restriction
first capture.png
first capture.png [ 151.69 KiB | Viewed 5507 times ]

Author:  KaZeR [ 11 Aug 2015, 20:24 ]
Post subject:  Re: routing problem

We can definitely look into this. Can you share the exact coordinates ? I can probably figure them out from your map otherwise, but if you have the coordinates it would help :)

Author:  Tuxi [ 13 Aug 2015, 06:26 ]
Post subject:  Re: routing problem

hello Kazer

the coordinate can be see on my first post : click on the link here :
http://www.openstreetmap.org/export#map ... 97/2.03458

thanks

Author:  Jandegr [ 30 Aug 2015, 16:51 ]
Post subject:  Re: routing problem

Hi,
the turn restriction was missing a via member, this is not mandatory in OSM but Navit and apparently OSRM too ignore those without a via member.

After adding the via member Navit makes a detour of over 7 km..
OSRM does not seem to update their maps often.

To handle this (and many more cases), Navit needs to use an extended routing graph or use contraction as OSRM does.

Below is the output of a test with an extended routing graph, no waypoints or other tricks used whatsoever.

Image

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/