navit-project.org
http://forum.navit-project.org/

House number search problems - SOLVED
http://forum.navit-project.org/viewtopic.php?f=7&t=599
Page 1 of 2

Author:  Eala [ 04 May 2016, 03:39 ]
Post subject:  House number search problems - SOLVED

Hi Folks,

I am new to Navit and running it on an RPi. So far I have been able to set up a lot of things the way I like, but I am having an issue I can't solve.

I can go through the Town, Street, then House Number search, but when I try to enter a house number, it only allows me to enter one number then it enters a loop or something where the GUI is not very responsive. I can't back out or stop the program without killing it.

I started Navit in debug mode 0 and the terminal window is just repeating the phrase:

navit:search_list_get_result:interpolation!

again and again. Doesn't allow me to interact at all with it.

Any thoughts on what is wrong? Perhaps I missed something in the setup or docs.

Thanks,
Eala

Author:  Eala [ 14 May 2016, 13:41 ]
Post subject:  Re: House number search problems

Anybody?

Author:  tryagain [ 20 May 2016, 22:16 ]
Post subject:  Re: House number search problems

Hi!

Can you give us some more details: what version of Navit do you use, is it a self compiled binary, or you've got it from some repo, what map source and version do you use?

An example of Country, Town, Street where the problem reproduces, could also be helpful.

Eala wrote:
Any thoughts on what is wrong? Perhaps I missed something in the setup or docs.


Actually, this doesn't look like a common problem... Maybe we'll be able to reproduce and fix it if we have more details...

tryagain.

Author:  Eala [ 22 May 2016, 02:34 ]
Post subject:  Re: House number search problems

Awesome. Thanks for the help tryagain.

Ok, I have tried this a whole bunch of times with many addresses and a couple versions. I am using Openstreetmaps for Canada. I grabbed the bin file myself about a month ago. It works great and I can use the software just fine with the exception of locating a house number. Navigation works great.

The problem occurs with ANY search of house number. Basically, you can just type in a random town, then a random street, then as soon as you hit the house number button and then enter your first number, it hangs. It shows that number in the box, but you can't enter any more numbers.

1. I have used a precompiled version (somebody else compiled it). It is 0.5.0 5917M-. I downloaded a prebuilt RPi image file and tried it. Same problem.
2. I installed from the repo for Raspbian Jessie many times (mostly as a result of trying to get my GPS sensor working, but I am past that). Once I get navit configured to load the map and connected to the GPS, I try the filter for house number and it hangs. I am also using 0.5.0 from the repo for Raspbian Jessie.

I am currently trying to configure it one more time to see if something is different.

Any tips?

eala

Author:  Pat P. [ 29 May 2016, 12:53 ]
Post subject:  Re: House number search problems

I am having exactly the same problem.
Raspberry pi2 with Carpc distro running Raspbian Wheezy
Also using same maps.

Author:  tryagain [ 30 May 2016, 16:58 ]
Post subject:  Re: House number search problems

Hi!

I have tried to reproduce this problem on a desktop linux, using current version https://github.com/navit-gps/navit/releases/tag/R6666 and version R5917. The latter, btw, almost 2 years old.

I was able to find lots of house numbers on the Indian Road of Toronto, Canada. I was using the latest map from maps.navit-project.org (tagged 160521). To do the search, I select the first item named Toronto in town search (the second one seems to be a tiny hamlet).

I guess, the problem may be related to the changes made to the code (letter M after revision number means it was modified before compilation). Also it may be related to low performance of Raspberry Pi. So maybe trying some smaller town and/or waiting longer would have some effect.

I do not have an RPi, so can not try it exactly in your environment.

Also there's alternative house number search method: after selecting a town, go to POIs, select the looking glass icon, then enter house number and partial street name and press the envelope icon. This is only a workaround, because it does not use house number interpolation and does not check town boundaries, but it might be useful to see what results do you get with it.

tryagain.

Author:  Pat P. [ 30 May 2016, 19:02 ]
Post subject:  Re: House number search problems

I don't think it has anything to do with the pi being too slow. I seem to be the only person having that issue with the carpc distro. I am using the pi2 which is quite a bit faster than the pi - which is what most use to run the carpc.
Thought it could be a map issue, as I am using a different version of the OS than Eala.
I'll try to reload a newer map and see if that helps. Thanks for your support.

Author:  tryagain [ 30 May 2016, 20:31 ]
Post subject:  Re: House number search problems

Sorry for a misleading comment, I was testing two current versions.

I actually can reproduce this problem on desktop linux with vanilla R5916 navit. On my sample with Indian Road, after pressing "2", it shows two house numbers and then hangs, displaying "navit:search_list_get_result:interpolation!" in console.

Shame on us, there's map incompatibility introduced at some point, and it's impossible to use current maps with older program versions. Usually we keep map backward compatibility better.

So you'll have to update navit to use maps from our map server, or build your own map from raw osm data with older maptool. I would strictly suggest going the first way.

If you'd be happy with current version, I would suggest to work on pushing an update to official RPi repos.

Author:  Eala [ 31 May 2016, 11:09 ]
Post subject:  Re: House number search problems

Thanks so much for the replies. Glad to know I am not alone here.

Ok, I can update navit to a newer version. I am assuming this means I need to download and compile it on my Pi. I will poke around for instructions here. If you can provide a link it would greatly help as this is not a normal thing for me.

Thanks!
eala

Author:  Eala [ 31 May 2016, 21:28 ]
Post subject:  Re: House number search problems

Tryagain,

I must have read your post too fast this morning. You said I have to download maps from your server. This is where I downloaded the map originally:
http://maps9.navit-project.org/

So, could you provide just a bit more guidance. I am not 100% sure how to resolve.

Thanks,
eala

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/