Custom POI does not appear
Page 1 of 1

Author:  es330 [ 28 Feb 2017, 08:19 ]
Post subject:  Custom POI does not appear

Dear all,
I’m working in a project that requires a navigation engine on Raspberry Pi. I’m using raspberry pi 3 running with raspbian jessie PIXEL latest version. Also I have installed navit version(navit-svn 0.5.0 6135- from this tutorial: . And I’m interested to use my own custom POI, I have followed this tutorial: which is about inserting a custom POI from a text file. But it didn’t display the icon, the desired location is 23.6184444 N, 58.1799386 E.

In my_pois.txt look like this:
mg:58.1799386 23.6184444 type=poi_custom1 label="speed" icon_src="airport_96_96.png"

And in xml file like this:

<!-- Mapset template for openstreetmaps -->
      <mapset enabled="yes">
         <map type="binfile" enabled="no" data="/media/mmc2/MapsNavit/osm_europe.bin"/>
         <map type="binfile" enabled="yes" data="/home/pi/navit/maps/osm_oman.bin"/>
         <map type="textfile" enabled="yes" data="/home/pi/navit/maps/my_pois.txt"/>

I have tried to put the icons full path in “icon_src” as Mr. Malcolm did it in . Also, I ‘ve tried to change the order in xml (0- to 20-) but seems it didn’t work either.
In navit, my_pois.txt file is activated in settings >> maps but nothing appears on the map!

Any suggestion?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group