navit-project.org
http://forum.navit-project.org/

launching the Navit Application in Intel yocto platform
http://forum.navit-project.org/viewtopic.php?f=6&t=623
Page 1 of 1

Author:  Lavakumar S [ 08 Feb 2017, 04:17 ]
Post subject:  launching the Navit Application in Intel yocto platform

currently I am working on Navit-0.5.0 on intel yocto Linux platform.
where in all my applications(Gui as well services) working fine with Qt5.4.1.

I am able to build the Navit on the platform. but facing difficulties in launching it . also not finding any error messages either.

Only I can run and see some logs with pthread created. after that application hangs.
Procedure followed. 1. export QT_QPA_PLATFORM=wayland
2. ./navit -c ~/.navit/navit.xml

available platforms : wayland , x11 , kms etc

Note: unable to see the Navit window.

Help me with solution.
Thanks

Author:  Lavakumar S [ 15 Mar 2017, 05:14 ]
Post subject:  Re: launching the Navit Application in Intel yocto platform

actually navit window with maps comes only if tty is changed..
(i.e. after pressing ctrl+alt+f1 and ctrl+alt+f2)

can someone answer how to resolve this issue..?

I wan to see the navit window without changing the tty terminal (obviously)

Regards,
Lavakumar

Author:  KaZeR [ 07 May 2017, 04:06 ]
Post subject:  Re: launching the Navit Application in Intel yocto platform

That's really weird.

Can you join us on IRC for a live chat to investigate the issue and fix this? We are mostly active during western europe's evenings : http://wiki.navit-project.org/index.php/Contacts#IRC

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/