navit-project.org

forum for navit navigation tool
It is currently 22 Oct 2017, 10:06
View unanswered posts | View active topics


All times are UTC


Forum rules


Feel free to ask anything here related to the development process - coding, creating new features, fixing bugs and custom changes of Navit.

Note: For reporting bugs, use the bug tracker.



Post new topic Reply to topic  [ 13 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Help me about navit on Linux Embedded System !
PostPosted: 01 Jul 2013, 08:13 
Offline

Joined: 01 Jul 2013, 07:49
Posts: 8
Hi everybody !

I'm Vietnamese. I want to develop a Navigate System based FriendlyARM Mini2440 (http://www.friendlyarm.net/products/mini2440) using Qtopia OS. I follow tomtom project support in navit website because i see their hardwave is alike. Please show me :

1-Can I use libraries of Tomtom for my device ?
2-Everyone show me howto navit action?

I was compile navit successfully and ported in My Mini2440. But I run navit, in navit.log report error : No plugins found. I don't know how to fix this error. Everyone help me ?

Importantly, I wanna understand fully how to navit operate and understand fully about navit-project, what can I do ? Everyone help me. please !

Thanks for read and reply. Sorry because my English.


Last edited by Kdich199 on 01 Jul 2013, 09:27, edited 1 time in total.

 Profile  
 
 Post subject: Re: Help me about plugins in Navit !
PostPosted: 01 Jul 2013, 08:50 
Offline
User avatar

Joined: 07 Jun 2013, 09:32
Posts: 200
Location: Rostock, North Germany
We will give it at least a try ;)

Please provide us more details: Which navit version/build are you running on which device under which OS?


 Profile  
 
 Post subject: Re: Help me about plugins in Navit !
PostPosted: 01 Jul 2013, 09:22 
Offline

Joined: 01 Jul 2013, 07:49
Posts: 8
usul wrote:
We will give it at least a try ;)

Please provide us more details: Which navit version/build are you running on which device under which OS?



Thanks very much for your repply and regarded me!

I port navit stable version downloaded by link :https://navit.svn.sourceforge.net/svnroot/navit/trunk/navit
My device is FriendlyARM Mini2440 (ARM9) and Qtopia OS (Based Debian Linux). It's alike Tomtom device which navit supported.

Can you send me document which describe operation of navit ? I very need it. Thanks so much.
my mail : kieuvietdich@gmail.com


 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 01 Jul 2013, 09:27 
Offline

Joined: 01 Jul 2013, 07:49
Posts: 8
Sorry if my syntax English error. But, If you don't understand what I talking. please tell me. I try to fix it for you understand.

Thanks you !


 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 01 Jul 2013, 15:58 
Offline
User avatar

Joined: 07 Jun 2013, 17:13
Posts: 146
Location: Tartu, Estonia
Could you please upload the complete navit.log and possibly also a build log?

I don't know anything about Qtopia OS or about the FriendlyARM Mini2440, so I don't know which libraries are required and which will work. But it's easiest to get things like SDL running, so the TomTom guide might also work on other devices.


 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 02 Jul 2013, 12:05 
Offline
User avatar

Joined: 07 Jun 2013, 09:32
Posts: 200
Location: Rostock, North Germany
I merged both of your requests to provide all informations at one single place.


 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 19 Jul 2013, 19:53 
Offline

Joined: 01 Jul 2013, 07:49
Posts: 8
xenos1984 wrote:
Could you please upload the complete navit.log and possibly also a build log?

I don't know anything about Qtopia OS or about the FriendlyARM Mini2440, so I don't know which libraries are required and which will work. But it's easiest to get things like SDL running, so the TomTom guide might also work on other devices.



Thanks for reply !
I cross compile successfully navit and libraries which suppport it ! I thinks so !
But, I run navit on my board terminal report : Segmentation fault !

I debug navit on board and result :

Code:
[root@FriendlyARM bin]# gdb
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "arm-none-linux-gnueabi".
(gdb) file navit
Reading symbols from /sdcard/navit/bin/navit...done.
(gdb) run
Starting program: /sdcard/navit/bin/navit
setting 'NAVIT_PREFIX' to '/sdcard/navit'
map_rect_new_textfile unable to open textfile /sdcard/navit/.navit/bookmark.txt
navit:convert_to_attrs:failed to create attribute 'weight' with value '36287'
navit:convert_to_attrs:failed to create attribute 'axle_weight' with value '15422'
navit:xinclude:Unable to include /sdcard/navit/share/navit/maps/*.xml

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) where
#0  0x00000000 in ?? ()
#1  0x00020564 in graphics_get_data ()
#2  0x401964a4 in gui_internal_set_graphics () from /sdcard/navit/lib/navit/gui/libgui_internal.so
#3  0x00025120 in gui_set_graphics ()
#4  0x0002cf40 in navit_init ()
#5  0x0001887c in xi_end_element ()
#6  0x00000000 in ?? ()


Below (LogNavit.txt)that is terminal report when I run navit with command : LD_DEBUG=all navit
Please help me ! Thanks very much !


Attachments:
LogNavit.txt.tar.gz [94.6 KiB]
Downloaded 218 times


Last edited by usul on 20 Jul 2013, 08:23, edited 1 time in total.
soft formating
 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 19 Jul 2013, 20:45 
Offline

Joined: 01 Jul 2013, 07:49
Posts: 8
This is my navit.xml file.


Attachments:
navit.xml [204.5 KiB]
Downloaded 207 times
navit.xml [204.5 KiB]
Downloaded 192 times
 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 20 Jul 2013, 08:27 
Offline
User avatar

Joined: 07 Jun 2013, 09:32
Posts: 200
Location: Rostock, North Germany
Do you have tested the SDL support already with another application?

A logfile with less informations would be very helpful in a first step to review your setup and how navit adapts it.


 Profile  
 
 Post subject: Re: Help me about navit on Linux Embedded System !
PostPosted: 21 Jul 2013, 16:37 
Offline

Joined: 01 Jul 2013, 07:49
Posts: 8
Thanks !

I think so, too. I need to test SDL. I haven't do this yet. I'll try it.


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Silver Orange 2.0.6 for IPB Designed by Skins and Hosting
Converted for phpBB3, based on Royal Blue template by BigB © 2007 2008 AEON KINGS