navit-project.org
http://forum.navit-project.org/

Problems on Huawei Matepad, Android 10
http://forum.navit-project.org/viewtopic.php?f=12&t=782
Page 1 of 1

Author:  Else [ 28 Jun 2021, 16:08 ]
Post subject:  Problems on Huawei Matepad, Android 10

System information: Huawei Matepad 10.4, 3GB RAM, 32GB Flash, 128GB microSD, resolution 2000x1200, NOT rooted.

As you may know, Huawei devices sold in Germany come without Google services - that's one of the reasons why I chose it.
I installed Navit 0.5.6 from APK, downloaded from navit-project.org on April 29.
Before, I had tried Navit 0.5.4 on Windows XP and it seemed to work well. I didn't get it to run on Windows Mobile 5, the device (Asus MyPal) seems to be too slow and lacks memory.
Because I didn't want to download the map again (internet connection is bad, and there are known problems with planet extractor) I copied it to Android/data/org.navitproject.navit/files/navitmap.bin on the pads SD-Card. I have set the default storage location to SD-Card in the system settings. Navit finds this map and uses it, so that's fine.
I placed a custom navit.xml file in the same folder which seems to get evaluated. In it I created a custom vehicle profile named "Car_slow" which is displayed in the vehicle settings and used by default as specified.

I would like to use a north oriented map in 2D view for navigation, but it seems to be impossible to get that.
The settings made in navit.xml seem to be overwritten by something else.
Changing the view using the on-screen menu doesn't work either.
When tapping the "2D" button the menu closes and for the fraction of a second the map is displayed in 2D view, but turns back into 3D view immediately.
Trying to enable "Norting" in the Rules menu is similar. After tapping the grey cross it turns into a green checkmark and back again faster than I am able to close the menu.
I have noticed some other strange behavior in that context: When I pan the map (by putting the finger on it and moving it) the view turns into 2D after the first panning and gets north oriented after the second. But as soon as the car cursor leaves the screen and the map gets repainted and turns back to 3D rotating view.

What's going on there? Am I doing something wrong or is it a bug?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/