Custom Maps Not Showing, Street Names, & Building Maptool
Page 1 of 1

Author:  rytz [ 06 Mar 2017, 11:53 ]
Post subject:  Custom Maps Not Showing, Street Names, & Building Maptool

Running the latest Navit source on a Raspberry Pi 3 under Raspbian. Also did some Windows testing on the latest releases to confirm map issues.

Scenario: Navit built and working. The included Munich map work on first and subsequent runs. Downloaded maps require more steps that aren't obvious. I'm trying to understand why these steps are required.

[Downloaded Maps]
In order for downloaded / custom maps to show, I have to do the following:

[1] Click on the Navit interface to get the options menu screen. Click on "Actions" and then "Town".
[2] Search for and click on a town that is part of the custom map.
[3] Click "View on Map".
[4] The map should update and the be visible now, centered on the selected town. If not, try exiting and re-entering Navit.

Without the above steps, I tried deleting the center.txt and changing the center option in the navit.xml. My navit.xml is configured correctly. The above steps is the only way I can get a new downloaded map to show. After that, the map does continue to work after exiting and restarting.

[Street Names & Zoom Levels]
How do I set the zoom level required for displaying street names? I'd like to have street names show up without having to zoom in so much. I'm using the Car-Android layout.

[Building Maptool]
When building maptool from source with a cmake/make, I get the following error:
Scanning dependencies of target maptool_core
[  8%] Building C object navit/maptool/CMakeFiles/maptool_core.dir/boundaries.c.o
In file included from /home/pi/.navit/navit-trunk/navit/maptool/boundaries.c:21:0:
/home/pi/.navit/navit-trunk/navit/maptool/maptool.h:423:31: error: size of array `s' is negative
 struct maptool_force_64 {char s[sizeof(gpointer)<sizeof(osmid)?-1:1];};
navit/maptool/CMakeFiles/maptool_core.dir/build.make:62: recipe for target 'navit/maptool/CMakeFiles/maptool_core.dir/boundaries.c.o' failed
make[2]: *** [navit/maptool/CMakeFiles/maptool_core.dir/boundaries.c.o] Error 1
CMakeFiles/Makefile2:2175: recipe for target 'navit/maptool/CMakeFiles/maptool_core.dir/all' failed
make[1]: *** [navit/maptool/CMakeFiles/maptool_core.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

I commented that line in maptool.h and the build works. Tested a PBF map converted with maptool.

Any info on this?

[Raspberry Pi 3 Performance]
I'm running Navit with the following options:
> graphics type="gtk_drawing_area"
> drag_bitmap="1"
> layout: Car-Android

Is there any other way to improve rendering performance on RPi2? Tried the other graphics types and had the same results or other problems with maps showing up (opengl).


[Edited - mistakenly put Raspberry Pi 2]

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group