Navit Configurator compile issue...
Page 1 of 1

Author:  dreadscott [ 28 Nov 2017, 09:18 ]
Post subject:  Navit Configurator compile issue...

Hello, I'm trying to compile the Navit Configurator on my Raspberry Pi 3 running a fully updated Stretch kernel. This is being done from source following the information here: ... stallation

This is what I get. Can anyone advise me as to what's going wrong? I don't know how to interpret the error:

pi@raspberrypi:~/navit-build/navit/navitconfigurat-code $ make
make -f Makefile.Release
make[1]: Entering directory '/home/pi/navit-build/navit/navitconfigurat-code'
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4 -Isrc -Isrc/zlib -Irelease -I. -o release/TableComboBox.o src/navitconf/gui/mapview/TableComboBox.cpp
In file included from src/navitconf/gui/mapview/TableComboBox.cpp:19:0:
src/navitconf/gui/mapview/TableComboBox.h:24:31: fatal error: QtWidgets/QComboBox: No such file or directory
#include <QtWidgets/QComboBox>
compilation terminated.
Makefile.Release:393: recipe for target 'release/TableComboBox.o' failed
make[1]: *** [release/TableComboBox.o] Error 1
make[1]: Leaving directory '/home/pi/navit-build/navit/navitconfigurat-code'
Makefile:34: recipe for target 'release' failed
make: *** [release] Error 2

Author:  zintor [ 22 Mar 2018, 19:42 ]
Post subject:  Re: Navit Configurator compile issue...

hi dreadscott,

did you contact the developer of navit configurator?

Kind regards ,

Author:  pinheads [ 18 Jul 2018, 06:53 ]
Post subject:  Re: Navit Configurator compile issue...

Good morning
I have the same error with compiling on rpi3 and stretch with navit.Is there nobody who tried this without errors? or any solution?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group