navit-project.org
http://forum.navit-project.org/

[Solved] Bug: Navigation to a wrong address
http://forum.navit-project.org/viewtopic.php?f=9&t=447
Page 1 of 1

Author:  efred [ 07 Oct 2013, 13:19 ]
Post subject:  [Solved] Bug: Navigation to a wrong address

There are in 2 villages near of me, residential-streets with the same name: Eigerweg

in Bösingen: http://www.openstreetmap.org/?mlat=46.8 ... 91/7.22662
and in Laupen bei Bern: http://www.openstreetmap.org/?mlat=46.8 ... 30/7.24130

If I want to navigate to Bösingen, Eigerweg 7 (Navit find it - housenumber is mapped in OSM), it allways want to navigate to the Eigerweg in Laupen (there are no housenumbers, till now).

Author:  usul [ 07 Oct 2013, 13:30 ]
Post subject:  Re: Bug: Navigation to a wrong address

But the postalcode ist the right one in the streetlist?

Author:  efred [ 07 Oct 2013, 13:59 ]
Post subject:  Re: Bug: Navigation to a wrong address

usul wrote:
But the postalcode ist the right one in the streetlist?

If I search for Bösingen, Navit won't show a postalcode. But at the boundary-Multipolygon and at the housenumber, there is the correct postalcode: 3178
At the POI place=village, there was no postalcode. I've added it and I've added also a is_in at this node.

I will check it tomorrow, but I think, it will navigate me to Laupen again.

Author:  Mapmapper [ 07 Oct 2013, 18:08 ]
Post subject:  Re: Bug: Navigation to a wrong address

Multipolygon-Bounderies are not supported, it seems so. Bounderies with postal code yes, Multipolygon no. is_in is still important

Author:  usul [ 07 Oct 2013, 21:39 ]
Post subject:  Re: Bug: Navigation to a wrong address

So maybe this is related to #1097?

Author:  efred [ 17 Oct 2013, 13:04 ]
Post subject:  Re: [Solved] Bug: Navigation to a wrong address

Now, with SNV 5655 of Maptool - viewtopic.php?p=760#p760 - its routing to the correct address.

Author:  Mapmapper [ 22 Oct 2013, 10:11 ]
Post subject:  Re: [Solved] Bug: Navigation to a wrong address

efred, do you think, that Navit now works with postal_code-boundaries? Could you type in only a postal code and Navit find it? That would be great!

Author:  Millesimus [ 12 Feb 2017, 13:56 ]
Post subject:  Re: [Solved] Bug: Navigation to a wrong address

I'm not sure, if this is the right place to post it (or if trac or something would be a better place to do so), but I have quite the same problem with the "Trierer Straße" in "66111 Saarbrücken".

When I tried to navigate to this street, having chosen the only "Trierer Straße" navit showed me after clicking on 66111 Saarbrücken, navit led me to this road in 66125 Dudweiler (apparently, Dudweiler is part of the Saarbrücken administrative boundary).

The map I used has been download from maps9.navit-project.org so I assume they were created with the latest version of maptool.

Author:  KaZeR [ 07 May 2017, 03:58 ]
Post subject:  Re: [Solved] Bug: Navigation to a wrong address

Millesimus, can you please file a bug report using Trac? This will get more visibility than the forum.

Thanks!

Author:  Jandegr [ 17 May 2017, 15:23 ]
Post subject:  Re: [Solved] Bug: Navigation to a wrong address

Navit maptool maps boundaries for Germany like this :
{ 276,"Germany,Deutschland,Bundesrepublik Deutschland","345c7M"},

In human understandable, that would be level 6 is mapped to county and level 8 is mapped to town.

http://wiki.openstreetmap.org/wiki/Tag:boundary%3Dadministrative

The search is done with attr_town_or_district_name, so the behaviour is more or less as it is coded.

Serveral options are available now :
- drop the county mapping for Germany only
- change the search to attr_town, but since Navit tries to provide a global solution with only one codebase that might break some seraches somwhere on the planet.
- change the duplicate check in binfile to make it offer you both alternatives (66111 and 66125) a s a choice

Btu I fail to duplicate the issue with any version of navit :)

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/