navit-project.org

forum for navit navigation tool
It is currently 24 Jun 2017, 19:10
View unanswered posts | View active topics


All times are UTC


Forum rules


Feel free to ask anything here related to the development process - coding, creating new features, fixing bugs and custom changes of Navit.

Note: For reporting bugs, use the bug tracker.



Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: No images or icons displayed on TomTom One
PostPosted: 31 Oct 2013, 09:36 
Offline
User avatar

Joined: 30 Oct 2013, 10:45
Posts: 5
Hello,

as I mentioned in the "INSTALLATION" board, I came to a point, where
TTNavit starts, but there is no graphics displayed, as the log file confirms.
However, all failing files are in place (see my posting there).

My TomTom One displays as follows in "lsusb":
Bus 004 Device 002: ID 1390:0001 TOMTOM B.V. GO 520 T/GO 630/ONE XL (v9)
It has a file "appver.txt" reading "release:1.0 build 1014", and I found a release.nfo (attached).

Now, I raised the log levels, and here is just a section of the 5M output:

Code:
14:02:56.925|navit:main_real:Using config file '/mnt/sdcard/navit/share/config/tomtom320.xml'
14:02:56.927|navit:callback_call:cb->pcount=1
14:02:56.927|navit:callback_call:cb->p[0]=0x89160
14:02:56.927|navit:callback_call:pcount=2
14:02:56.927|navit:callback_call:p[0]=0x140
14:02:56.930|gui_internal:gui_internal_resize:w=320 h=240 children=(nil)
14:02:56.930|navit:transform_setup_matrix:yaw=0 pitch=0 center=0x1268c0,0x6926f0
14:02:56.930|navit:transform_setup_matrix:scale_shift=1 order=13 scale=2.000000 fac=256.000000
14:02:56.931|navit:callback_call:cb->pcount=1
14:02:56.931|navit:callback_call:cb->p[0]=0x8d208
14:02:56.931|navit:callback_call:pcount=1
14:02:56.932|navit:callback_call:p[0]=0x80680
14:02:56.932|osd_core:osd_button_init:enter
14:02:56.933|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/minus64.png' for '/mnt/sdcard/navit/share/xpm/minus64.png' at -1x-1
14:02:56.934|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/minus64.svg' for '/mnt/sdcard/navit/share/xpm/minus64.png' at -1x-1
14:02:56.934|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/minus64.svgz' for '/mnt/sdcard/navit/share/xpm/minus64.png' at -1x-1
14:02:56.935|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/minus64.png' for '/mnt/sdcard/navit/share/xpm/minus64.png' at -1x-1
14:02:56.936|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/minus64.xpm' for '/mnt/sdcard/navit/share/xpm/minus64.png' at -1x-1
14:02:56.936|navit:graphics_image_new_scaled_rotated:No image for '/mnt/sdcard/navit/share/xpm/minus64.png'
14:02:56.936|osd_core:osd_button_init:failed to load '/mnt/sdcard/navit/share/xpm/minus64.png'
14:02:56.937|navit:callback_call:cb->pcount=1
14:02:56.937|navit:callback_call:cb->p[0]=0x8cfd8
14:02:56.937|navit:callback_call:pcount=1
14:02:56.938|navit:callback_call:p[0]=0x80680
14:02:56.938|osd_core:osd_button_init:enter
14:02:56.939|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/plus64.png' for '/mnt/sdcard/navit/share/xpm/plus64.png' at -1x-1
14:02:56.939|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/plus64.svg' for '/mnt/sdcard/navit/share/xpm/plus64.png' at -1x-1
14:02:56.940|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/plus64.svgz' for '/mnt/sdcard/navit/share/xpm/plus64.png' at -1x-1
14:02:56.940|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/plus64.png' for '/mnt/sdcard/navit/share/xpm/plus64.png' at -1x-1
14:02:56.941|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/plus64.xpm' for '/mnt/sdcard/navit/share/xpm/plus64.png' at -1x-1
14:02:56.941|navit:graphics_image_new_scaled_rotated:No image for '/mnt/sdcard/navit/share/xpm/plus64.png'
14:02:56.942|osd_core:osd_button_init:failed to load '/mnt/sdcard/navit/share/xpm/plus64.png'
14:02:56.942|navit:callback_call:cb->pcount=1
14:02:56.942|navit:callback_call:cb->p[0]=0x8cde0
14:02:56.943|navit:callback_call:pcount=1
14:02:56.943|navit:callback_call:p[0]=0x80680
14:02:56.943|graphics_sdl:overlay_new:overlay_new 0 0 176 64 64 (f800, 7e0, 1f ,0, 16)
14:02:56.944|navit:plugin_get_type:type="font", name="freetype"
14:02:56.945|navit:osd_std_config:enter
14:02:56.951|navit:osd_set_keypress:accesskey (null)
14:02:56.951|navit:callback_call:cb->pcount=1
14:02:56.951|navit:callback_call:cb->p[0]=0x8ca48
14:02:56.952|navit:callback_call:pcount=1
14:02:56.952|navit:callback_call:p[0]=0x80680
14:02:56.952|graphics_sdl:overlay_new:overlay_new 1 0 112 64 64 (f800, 7e0, 1f ,0, 16)
14:02:56.953|navit:plugin_get_type:type="font", name="freetype"
14:02:57.096|navit:osd_std_config:enter
14:02:57.100|navit:osd_set_keypress:accesskey (null)
14:02:57.101|navit:tracking_get_attr:enter position_speed
14:02:57.106|navit:callback_call:cb->pcount=1
14:02:57.106|navit:callback_call:cb->p[0]=0x8c648
14:02:57.106|navit:callback_call:pcount=1
14:02:57.107|navit:callback_call:p[0]=0x80680
14:02:57.107|graphics_sdl:overlay_new:overlay_new 2 0 64 64 48 (f800, 7e0, 1f ,0, 16)
14:02:57.108|navit:plugin_get_type:type="font", name="freetype"
14:02:57.108|navit:osd_std_config:enter
14:02:57.112|navit:osd_set_keypress:accesskey (null)
14:02:57.113|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' at 32x32
14:02:57.113|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' at 32x32
14:02:57.114|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/gui_strength_1.svg' for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' at 32x32
14:02:57.114|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/gui_strength_1.svgz' for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' at 32x32
14:02:57.115|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/gui_strength_1.png' for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' at 32x32
14:02:57.116|navit:image_new_helper:Trying to load image '/mnt/sdcard/navit/share/xpm/gui_strength_1.xpm' for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png' at 32x32
14:02:57.116|navit:graphics_image_new_scaled_rotated:No image for '/mnt/sdcard/navit/share/xpm/gui_strength_1_32_32.png'
14:02:57.117|navit:callback_call:cb->pcount=1
14:02:57.117|navit:callback_call:cb->p[0]=0x8c390
14:02:57.117|navit:callback_call:pcount=1
14:02:57.118|navit:callback_call:p[0]=0x80680


Any hints? I will also attach /media/INTERNAL/navit/share/config/tomtom320.xml
Thanks
M


Attachments:
tomtom320.xml [3.67 KiB]
Downloaded 250 times
 Profile  
 
 Post subject: Re: No images or icons displayed on TomTom One
PostPosted: 31 Oct 2013, 11:59 
Offline
User avatar

Joined: 07 Jun 2013, 09:32
Posts: 200
Location: Rostock, North Germany
So the Dev Docs say, that you (maybe) should copy the icons manually:
http://wiki.navit-project.org/index.php ... _and_icons

But plz. wait for Xenos1984 for a response, as he maintains the TomTom port :)


 Profile  
 
 Post subject: Re: No images or icons displayed on TomTom One
PostPosted: 31 Oct 2013, 17:07 
Offline
User avatar

Joined: 07 Jun 2013, 17:13
Posts: 146
Location: Tartu, Estonia
So apparently the icons are in place, but still Navit cannot load them. So there is probably some other problem. Could you please check if you have libpng on your system, and which version you have? This library does the actual image loading. I remember that once I had some version incompatibilities with this, and also there the icons were missing.


 Profile  
 
 Post subject: Re: No images or icons displayed on TomTom One
PostPosted: 19 Nov 2013, 19:29 
Offline
User avatar

Joined: 07 Jun 2013, 17:13
Posts: 146
Location: Tartu, Estonia
The last working version seems to be 5532, so maybe you can try that. I will also put up a new version, maybe this fixes the problem.


 Profile  
 
 Post subject: Re: No images or icons displayed on TomTom One
PostPosted: 22 May 2014, 07:42 
Offline
User avatar

Joined: 07 Jun 2013, 17:13
Posts: 146
Location: Tartu, Estonia
Maybe the problem was undefining SDL_IMAGE in graphics_sdl.c in version 5567, since the SDL image library is actually used for image loading on TomTom. I have reverted this change in version 5779 and uploaded a newly compiled version here:

http://www.navit-project.org/~xenos1984/navitom.tar.gz

Please try and let me know whether the problem still exists. Unfortunately I cannot test myself because I have no TomTom device here.


 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Silver Orange 2.0.6 for IPB Designed by Skins and Hosting
Converted for phpBB3, based on Royal Blue template by BigB © 2007 2008 AEON KINGS